Resolved
This incident has been resolved we put a fix in place and verified all connections have been restored and Meetings are fully operational for these Microsoft Calendar services
Identified
We have identified the issue impacting our connections to Microsoft Calendars preventing meeting bookings. The team is currently working on a fix. We will update as the fix is in place.
Investigating
We are currently investigating reports of Calendar connection issues with Microsoft calendars. Users with Microsoft calendars will not be able to have meetings booked on their calendar during this time. We will provide an update as the cause is identified and a fix is put in place.